testnet release issue
Incident Report for Pagoda
Resolved
This incident has been resolved.
Posted Jan 30, 2024 - 17:12 UTC
Investigating
We are currently investigating this issue.
Posted Jan 29, 2024 - 17:10 UTC