Explorer Mainnet
Incident Report for Pagoda
Resolved
This incident has been resolved.
Posted Sep 15, 2023 - 00:32 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Sep 15, 2023 - 00:05 UTC
Update
We are continuing to investigate this issue. Please use nearblocks.io
Posted Sep 14, 2023 - 19:43 UTC
Investigating
We are currently investigating this issue.
Posted Sep 14, 2023 - 18:08 UTC
This incident affected: Pagoda (Explorer - Mainnet).